CVE DatabaseCVE-2026-119977
한국어 권고문 →
CVE-2026-1199778.1/HIGHCISA KEVCWE-367

WordPress Core Remote Code Execution (RCE) Vulnerability Alert (CVE-2026-119977)

Affected Vendors
WordPress
Affected Components
WordPress Core
Published Date
2026-10-31

Executive & SecOps Summary

SECOPS ASSESSMENT
Affected Scope

WordPress Core versions 4.7 through 7.1.3

Impact

Unauthenticated attackers can execute arbitrary code on the server by exploiting predictable staging paths during the core upgrade process

Mitigation

Immediately upgrade to WordPress 7.1.4 or later and restrict web access to the upgrade staging directories

Affected Products & Version Scope

All WordPress installations running versions 4.7 to 7.1.3

Remediation & Live Workaround Commands

PATCH & WORKAROUND

1. Immediate Core Update Update your WordPress installation to version 7.1.4 or higher immediately via the dashboard or WP-CLI.

bash
# Update via WP-CLI
wp core update

2. Web Application Firewall (WAF) Configuration Implement WAF rules to block direct access to PHP files within the upgrade directory. For Apache (.htaccess):

apache
<Directory "/wp-content/upgrade">
    <FilesMatch "\.php$">
        Order allow,deny
        Deny from all
    </FilesMatch>
</Directory>

3. Hardening Staging Paths Ensure that the `wp-content/upgrade` directory is not indexable and that file permissions are strictly set to prevent unauthorized writes outside of the official update process.

Recommended Security Control & Mitigation Partner
Cloudflare Enterprise & Pro WAF
Apply the WordPress 7.1.4 security update immediately to mitigate the risk of remote code execution.

Block Exploits Instantly with Managed Virtual Patching Rules

Can't patch production immediately? Deploy managed WAF rules at the edge to intercept RCE, SQLi, and deserialization payloads before they hit your origin server.

3-min setup · Automated Zero-Day Managed Rules
Practice Exploiting & Patching This Web Vulnerability in an Interactive Lab
Launch Hands-On Security Lab

Technical Root Cause & Exploitation Mechanics

This vulnerability is a Time-of-Check Time-of-Use (TOCTOU) race condition (CWE-367) within the WordPress core update mechanism. During a full-package upgrade, WordPress extracts files into a predictable, web-accessible staging directory under wp-content/upgrade/. An attacker can predict this path and inject malicious scripts during the upgrade window. When the process completes and moves the staged files to the production root, the malicious payload is deployed and executed. With a high EPSS score of 0.94 and its inclusion in the CISA KEV catalog, this vulnerability is actively being exploited in the wild to compromise WordPress sites.

Official Vendor Advisories & References

SecOps Advisory Dispatch & RSS Feed

Subscribe to Daily Vulnerability Briefings & KEV Alerts

Concise morning briefings for SecOps, DevSecOps, and SRE teams covering newly exploited CVEs and mitigation priorities.

Slack / Teams / RSS Feed: